1. Ron

    Ron Premium Member Forum Donor

    Just found an old pic of Rosie, would like to see everyone elses!


    2009:

    [​IMG]


    and 2015:

    WP_20150709_16_34_53_Pro - Copy.jpg
  2. mati0921

    mati0921 Loyal Comrade

    Ron likes this.
  3. Ron

    Ron Premium Member Forum Donor

    That's not fair Mati, your 'before' is better than my 'after'!

    Car looks great.
  4. mati0921

    mati0921 Loyal Comrade

    i should never have painted it. i used the wrong primer so now rust is comming up everywhere. nothing beats old DDR paint, just dont eat it. :D
    Ron likes this.
  5. turbofiat124

    turbofiat124 Loyal Comrade

    I have yet to properly paint mine or replace the rusty sills (will do that this winter). I've just repainted the wheels, heat excahnger and front valance, touched up the engine compartment using a foam brush, gouges in the Duraplast, wetsanded and buffed the paint to get me by until I find the time.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
  6. Wartburg353W

    Wartburg353W Loyal Comrade

    K&N huh? Nice.
  7. turbofiat124

    turbofiat124 Loyal Comrade

    Yeah, it gives me about .000025 extra HP!
  8. michiel76

    michiel76 Loyal Comrade

    a1.jpg a2.JPG
    My 601 before and after.
    RogerDerSchrauber and Ron like this.
  9. Tim S

    Tim S Just Slow, Not Stalin Forum Donor

    WOW!

    May I ask what you used for cleaning your engine compartment?

    Mine has 40 years of crud on the painted surfaces and I don't want to use a cleaner that damages the surface. Also did you repaint you black metal or is that powdercoat? I am wondering if the original was powdercoat but I am guessing it was paint.

    THANKS!
  10. turbofiat124

    turbofiat124 Loyal Comrade

    I tried all sorts of stuff. Purple Magic, foaming engine cleaner, kerosene, hot water from my hot water heater. The only thing I did not try was a high pressure sprayer. I now own one.

    The only way I was able to actually clean it was when I had the engine/transmission and subframe out when I replaced the freewheel device.

    I used one of those gasket scrapers (grease was about 1/4" thick), a wire brush and kerosene in a spray bottle.

    It looked nice and clean about 1.5 years ago but the cylinder to engine block gaskets are leaking and now the underside of the engine is nasty again!

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
    michiel76 likes this.

Share This Page